title image


Smiley Anzahl bestimmter Wochentage (z.B. Samstage) in einem Zeitraum
Hallo zusammen!



Ich bin gerade auf der Suche nach einer Funktion, mit der man die Anzahl eines

bestimmten Wochentages innerhalb eines bestimmten Zeitraumes bekommt,

unter Berücksichtigung der Feiertage.



Ich hab' bei www.excelformeln.de auch was entsprechendes gefunden (siehe unten - Formel 251), die jedoch keine Feiertage berücksichtigt.



Vielleicht könnt Ihr mir da weiterhelfen, da das wahrscheinlich ungefähr einen Monat dauern würde, bis ich das selber raushabe ;-)



Hier die Funktionen aus excelformeln.de:



In B2 (Hilfszelle) steht:

=VERGLEICH(B1;{"Montag";"Dienstag";"Mittwoch";"Donnerstag";"Freitag";"Samstag";"Sonntag"};0)

oder als Array-Formel:

{=VERGLEICH(B1;TEXT(ZEILE(2:8);"tttt");0)}



das Ergebnis:

=WENN((A2-A1+1-(B2-WOCHENTAG(A1;2))-WENN(WOCHENTAG(A1;2)>B2;7;0))/7B2;7;0))/7;0))



Alternative als Array-Formel:

{=SUMME((WOCHENTAG(ZEILE(INDIREKT(A1&":"&A2));2)=B2)*1)}





Danke und viele Grüße aus München,

Andreas

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: