title image


Smiley Theoretische Lösung, allerdings nicht sehr praktikabel
Hallo Ilka Maria,



Theoretisch sähe eine Lösung folgendermaßen aus :

{=SUMMENPRODUKT(INDIREKT("A4:A"&MAX(WENN(A4:A2000"";ZEILE(4:2000))))*(INDIREKT("B4:B"&MAX(WENN(A4:A2000"";ZEILE(4:2000))))))}



Allerdings ist das nicht sonderlich praktikabel und performant, daher empfehle ich dir, Deine ursprüngliche Summenprodukt-Funktion stehen zu lassen, denn wenn z.B. in A nur Werte bis Zeile 1000 stehen, dann werden die Zeilen 1000 bis 2000 eben ignoriert (bzw. es wird nur 0 addiert).



Der einzige Grund, wann dieses Konstrukt einen Sinn ergäbe, wäre, wenn in den Zellen der Spalte B Fehlerwerte enthalten wären, so dass tatsächlich nur bis zur letzten gefüllten Zeile in Spalte A berechnet werden dürfte, hier ein Beispiel (vergleiche Funktionen in B2 und B3) :



Funktionen :

 AB2Fehler=SUMMENPRODUKT((A6:A20)*(B6:B20))3Funktion OK{=SUMMENPRODUKT(INDIREKT("A4:A"&MAX(WENN(A4:A2000<>"";ZEILE(4:2000))))*(INDIREKT("B4:B"&MAX(WENN(A4:A2000<>"";ZEILE(4:2000))))))}4  5  64=100/A675=100/A783=100/A89 =100/A910 =100/A10

Ergebnisse:

 AB2Fehler#DIV/0!3Funktion OK3004  5  642575208333,33333339 #DIV/0!10 #DIV/0!

Grüße, NoNet

  1,2,3 - kleine Excelei :   Infos + Anmeldung zum Jährlichen Exceltreffen



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: