title image


Smiley Probleme mit 'Wenn Funktion'
Hallo Experten, Excel zeigt mir mal wieder meine Grenzen auf.

Ich benutze folgende Formel, die soweit ich es überblicke auch funzt.



=WENN($A$4="erde";WENN(ODER(WOCHENTAG($A47)=1;WOCHENTAG($A47)=7;$B47="x";$B47="k";$B47="u");"";WENN(UND(WOCHENTAG($A47)=6;$D47="";$E47="");$G$2*-1;WENN(UND(WOCHENTAG($A47)=6;$I47<($G$2-$J$1/60);$H47="");$I47-G$2;WENN(WOCHENTAG($A47)=6;"";WENN(UND($D47="";$E47="");$G$1*-1;WENN(UND($I47<($G$1-$J$1/60);$H47="");$I47-$G$1+$J$1/60;""))))));WENN(ODER(WOCHENTAG($A47)=1;WOCHENTAG($A47)=7;$B47="x";$B47="k";$B47="u");"";WENN(UND(WOCHENTAG($A47)=6;$D47="";$E47="");$G$2*-1;WENN(UND(WOCHENTAG($A47)=6;$I47<$G$2;$H47="");$I47-G$2;WENN(WOCHENTAG($A47)=6;"";WENN(UND($D47="";$E47="");$G$1*-1;WENN(UND($I47<$G$1;$H47="");$I47-$G$1;"")))))))



Da ich einen wichtigen Punkt vergessen hatte, habe ich die Abfrage

WENN(MONAT($A47)>MONAT($A46);""; an den Anfang gesetzt, sieht dann so aus :



=WENN(MONAT($A47)>MONAT($A46);"";WENN($A$4="erde";WENN(ODER(WOCHENTAG($A47)=1;WOCHENTAG($A47)=7;$B47="x";$B47="k";$B47="u");"";WENN(UND(WOCHENTAG($A47)=6;$D47="";$E47="");$G$2*-1;WENN(UND(WOCHENTAG($A47)=6;$I47<($G$2-$J$1/60);$H47="");$I47-G$2;WENN(WOCHENTAG($A47)=6;"";WENN(UND($D47="";$E47="");$G$1*-1;WENN(UND($I47<($G$1-$J$1/60);$H47="");$I47-$G$1+$J$1/60;""))))));WENN(ODER(WOCHENTAG($A47)=1;WOCHENTAG($A47)=7;$B47="x";$B47="k";$B47="u");"";WENN(UND(WOCHENTAG($A47)=6;$D47="";$E47="");$G$2*-1;WENN(UND(WOCHENTAG($A47)=6;$I47<$G$2;$H47="");$I47-G$2;WENN(WOCHENTAG($A47)=6;"";WENN(UND($D47="";$E47="");$G$1*-1;WENN(UND($I47<$G$1;$H47="");$I47-$G$1;""))))))))



Nun geht nix mehr, alle meine Klammeränderungen bringen Fehler.

Gibt es jemanden, der mir dieses Rätsel lösen kann ?



Gruß

Dieter


Nobody isst perfekt, auch ich esse mit Messer und Gabel. DG

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: