title image


Smiley Re: Sudoku ohne VBA-Skript gibts bei Microsoft
Hallo Herby,



habe mir das Ding von Microsoft angesehen. Ist ja irgendwie irre. Es muss wohl so eine Art Sport unter den Formel-Freaks sein, es irgendwie hinzukriegen, dass man ganz auf VBA verzichtet. Ich werde es einfach nie begreifen, wie man sich solche Formel-Ungetüme wie



=WENN(ODER(GameState=0;$B$5=5;$B$15=5;UND($B$5="";ODER($B$15=5;$B$15="");$C$155;$D$155;$E$155;$F$155;$G$155;$H$155; $I$155;$J$155;$B$165;$B$175;$B$185;$B$195;$B$205;$B$215;$B$225; $B$235;$C$155;$D$155;$B$165;$C$165;$D$165;$B$175;$C$175;$D$175;ODER($AG$9"";$AJ$9"";$AM$9"";$AG$12"";$AJ$12"";$AM$12"");ODER($AP$9"";$AS$9"";$AV$9"";$AP$12"";$AS$12"";$AV$12"");ODER($AA$15"";$AA$18"";$AA$21"";$AD$15"";$AD$18"";$AD$21"");ODER($AA$24"";$AA$27"";$AA$30"";$AD$24"";$AD$27"";$AD$30"")));5;"")



antun kann, zumal die in den beiden Zellbereichen "Possible Numbers" und "Solution Numbers" gleich 1458 (!) solcher Ungetüme drin haben.

Und wozu das ganze? Bei folgendem Puzzle kann das Programm nicht EINE EINZIGE Zelle auflösen:



Sudoku Solver th {font-weight:normal}   9   7  17   83   25 764 971 8   2 5  7   9 93 4   7 2 7 3  484 3 87  1681 54 37  Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  





(Quelle: Sudoku für Profis, Fischer Taschenbuch Verlag, Abb. 7, S. 10)



Meine VBA-Anwendung, an der ich noch stricke, braucht auf einer 1-GHz-Krücke übrigens 0,44 Sekunden, um dieses Puzzle zu lösen. (Für die Experten: Hier muss man die Swordfish-Technik anwenden).



Naja, soll jeder machen, was er für sinnvoll hält.



Gruß an alle Sudoku-Fans!





rlx

(Ralf Lux)
mfg

Ralf

Der Computer löst Probleme, 
die es ohne ihn nicht gäbe!



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: