title image


Smiley Re: Frameset nachladen
Hallo Struppi,



ich glaube es nicht, es ist nicht nachvollziehbar.



Hier mal zwei Test.

Test1 mit iframe in meinem Code, es wird nur die einzeln aufgerufene Seite geladen:

http://www.iberiaholiday.info/eurorelais/index-TEST.php?code=MARBE-29680-25



im Test2 habe ich den iframe ersetz duch "ohne iframe", die Seite erscheint kurz und anschließend wird die komplette Seite geladen:

http://www.iberiaholiday.info/eurorelais/index-TEST2.php?code=MARBE-29680-25



Hier ist der Code für TEST:

1<?php2//========================3// index.php4//========================5//error_reporting(E_ALL);6session_start();7require('../languages/functions.inc.php');8?>910<?php11include ("../login_de/connect.inc.php");1213$query = "SELECT pathtxt,title FROM LINKER_LINK WHERE code='" . $code . "'";14$result = @mysql_query($query) or die (mysql_error());15while($row=@mysql_fetch_array($result))16 {17 $title = $row['title'];18 $pathtxt = $row['pathtxt'];19 }20//echo 'Titel:' .$title.'<br>';21//echo 'Pathtext:' .$pathtxt.'<br>';22?>2324<?php25//-------------------------------------26// Browser-Sprache festlegen über S_Session bzw.27// Browser-Sprache ermitteln, (wenn Seite direkt geladen wurde)28//-------------------------------------29 if(isset($_SESSION)) // wenn Session aktiv ist30 {31 $lang;32 }33 else // wenn keine Session aktiv ist, also die Seite einzeln aufgerufen wurde34 {35 include_once ('../languages/http_sprache.php');36 $allowed_langs = array ('de','en','es','fr');37 $lang = lang_getfrombrowser ($allowed_langs, 'en', null, false);38 }39?>40<?php echo 'Sprache: ' .$lang.'<br>'?>41<?php echo 'URL: ' .url.'<br>'?>42<?php echo 'Hauscode: ' .$code.'<br>'?>4344<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">45<html>46<head>47<title><?php echo $Villen_Appartmentvermietung;?>&nbsp;<?php echo $title;?>&nbsp;<?php echo $pathtxt;?></title>48<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">4950<script language="JavaScript">51<!--52function FramesetTest() {53if (top.frames.length==0) {54Address="http://<?php echo url;?>/index_<?php echo $lang;?>.html?http://<?php echo url;?>/eurorelais/i ndex.php?code=<?php echo $code;?>";55if(document.images) top.location.replace(Address);56else top.location.href=Address;57}58}59//-->60</script>6162</head>63<body onload="FramesetTest();">6465<br>6667<table border="0" width="780">68 <tr>69 <td width="70"></td>70 <td width="640">7172<iframe src="http://www.eurorelais.net/cgi/eris/extern/pvct/pvct.htm?pvct=zkhp&T=<?php echo $lang; ?>&Pt=imejost&Code=<?php echo $code;?>&Lo=93jd9d" frameborder="0" align="center" width="640" height="1650"></iframe>7374 </td>75 <td width="70"></td>76 </tr>77</table>7879</body>80</html>Powered by PHP Code Converter - © 2001-2003, faebu.ch



Rufe ich die Seite TEST2 dann normal über einen Link auf, erscheint nichts, außer "ohne Frame". Ich blicke nicht mehr durch.



Hast Du eine Idee?


mit freundlichen Grüssen
aus Neuwied
Airis

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: