title image


Smiley Re: Index, Vergleich und Indirekt
Hallo Werner,



du hast recht, die Zeilenangaben müssen absolut sein, wenn man die Formel runterkopieren will. Bei den Spaltenangaben ist es egal. Ob die Werte aus Tabelle2 in Spalte B oder C stehen, weiß ich nicht. Da hat Ralf sich widersprochen bzw. einmal verschrieben.



Damit komme ich zu dieser Formel:

=INDEX(Tabelle2!B:B;B$1+9+VERGLEICH(B2;INDIREKT("Tabelle2!B"&B$1+10&":B"&B$1+20);0))



Wenn nicht der gesamte Zellinhalte verglichen werden soll, sondern auch Teile der Inhalte in Tabelle2, dann so:

=INDEX(Tabelle2!B:B;B$1+9+VERGLEICH("*"&B2&"*";INDIREKT("Tabelle2!B"&B$1+10&":B"&B$1+20);0))



Wenn man die Zeilenermittlung für das erste Suchkriterium mit einbauen will, dann so:

=INDEX(Tabelle2!B:B;VERGLEICH("*"&A$1&"*";Tabelle2!A:A;0)+9+VERGLEICH("*"&B2&"*";INDIREKT("Tabelle2!B"&VERGLEICH("*"&A$1&"*";Tabelle2!A:A;0)+10&":B"&VERGLEICH("*"&A$1&"*";Tabelle2!A:A;0)+20);0))



Denn für die Zeilenermittlung reicht auch diese Formel:

=VERGLEICH("*"&A$1&"*";Tabelle2!A:A;0)



So ich muss jetzt los! Schönen Tag noch!
Gruß,



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: