title image


Smiley Re: Code funzt nicht
Hi Stefan,



ok, ich versuchs nochmal.



Also, ich hab zwei Tabellen. "tab_verbrauch" und "tab_anlieferung".

Die "tab_anlieferung" wird nun mit Datensätzen gefüllt, wo jeder

Datensatz eine eigene Bestellpositionsnummer hat. In einigen

Fällen hab ich auch Teillieferungen, wo ich dann auch mal zwei Datensätze

mit der gleichen Bestellpositionsnummer habe.



Beide Tabellen haben den identischen Tabellenkopf.

Nun soll das angelieferte Material, wenn es verbraucht wird auch in der

Datenbank als Verbrauchsdatensatz stehen.

Dazu hab ich ein Formular, mit zwei Textfeldern, in die der User erstens

die Bestellpositionsnummer eintragen soll, die zu dem Material gehört, das

er gerade verbraucht hat. Anschließend soll die verbrauchte Menge eingetragen

werden.



Anhand der Bestellpositionsnummer will ich nun erstmal den Anlieferungsdatensatz

für dieses Material in "tab_anlieferung" heraussuchen. Die darin stehenden Daten

wie Maße und Materialnamen sind ja die gleichen, die ich auch in meinem Verbrauchs-

datensatz benötige. Nur die Menge und der Status werden ja im Grunde verändert.

Status soll dann "verbraucht" sein.



Das bekomme ich aber irgendwie mit dem Code nicht realisiert. Statt in "tab_anlieferung" nun den Datensatz mit der eingetragenen Bestellpositionsnummer

herauszusuchen, nimmt Access einfach den ersten in "tab_anlieferung", und macht

mir daraus den Verbrauchsdatensatz, indem die Menge und der Status "verbraucht" eingetragen und in "tab_verbrauch" gespeichert wird.



Hmmm, hoffe jetz wars besser?



Gruß, Menzek.


Mit besten Grußen aus der Uckermark - Menzek.

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: