title image


Smiley DRINGEND: PHP-Update von PHP5.0.x beta auf PHP5.1.2 klappt nichtt :(
Hallo,



Ich habe folgendes Problem:



Auf einem Windows-Rechner habe ich PHP5.0.x beta installiert. Da gibt's eine php.exe in c:\php\



Jetzt habe ich mir auf www.php.net den Installer der Version PHP5.1.2 runtergeladen (CGI-only -> eine andere gibt's nicht mit Installer).



Ich habe nun die setup.exe gestartet, dann kam die Meldung, dass er in das httpd.conf des Apache nicht schreiben konnte. Ich dachte, das wäre eigentlich ja egal, weil die Endung .php dem Apache ja sowieso schon aus der alten Version bekannt sein muss.



Nun habe ich die Meldung mit OK weggeklickt, die Installation war nun fertig. Apache habe ich gestoppt und wieder gestartet. Aber phpinfo.php zeigt mir noch die alte Version an :(



Nun denke ich, dass es damit zu tun haben wird, dass er in httpd.conf nicht schreiben kann. Evtl. hat die Version (CGI-only) gar keine php.exe. Als ich nämlich nocheinmal installierte und vorher die c:\php\ umbenannte in c:\php_old\, wurde keine php.exe erstellt.



Kann mir jemand sagen was ich in die httpd.conf schreiben soll? Oder muss ich noch irgendwas mit CGI installieren damit PHP überhaupt rennt?



Oder soll ich nicht per Installer machen, sondern das ZIP Package? Das ist aber ziemlich kompliziert, oder?



Ich weiss nicht was ich machen soll, ich kenn mich zu wenig aus.



Bitte um Hilfe. Danke schon mal liebe Spotlight-Nutzer!

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: