title image


Smiley Re: jupp, ganau das...
Hallo Doc









Option Explicit

Sub doc()

Dim LRow As Long, z As Long, Spalte As String, NoNet As String, bst As Integer

Dim DocCode As String

Spalte = "A" 'das "A" anpassen

With Sheets(2) 'anpassen

LRow = .Cells(.Cells.Rows.Count, Spalte).End(xlUp).Row

For z = 1 To LRow

    NoNet = Cells(z, Spalte).Value

    For bst = 1 To Len(NoNet)

        DocCode = DocCode & DezimalZuBinär(Asc(Mid(NoNet, bst, 1)))

    Next

Cells(z, "B").NumberFormat = "@"

Cells(z, "B").Value = DocCode

Next

End With

End Sub



Function DezimalZuBinär(Zahl As Integer) As String

Dim Ausgabe As String

Dim Exponent As Long

If Zahl <= (2 ^ 8) - 1 And Zahl = Int(Zahl) Then

    For Exponent = 8 - 1 To 0 Step -1

        If Zahl >= (2 ^ Exponent) Then

            Ausgabe = Ausgabe & "1"

            Zahl = Zahl - (2 ^ Exponent)

        Else

                Ausgabe = Ausgabe & "0"

        End If

    Next Exponent

End If

DezimalZuBinär = Ausgabe

End Function











oder einfach so



 ABCDEFGHIJKL1NoNet0100111001101111010011100110010101110100      2Worti0101011101101111011100100111010001101001      3Doc Holiday0100010001101111011000110010000001001000011011110110110001101001011001000110000101111001



 ABCDEFGHIJKL1NoNet=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")=WENN(LÄNGE($A1)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A1;SPALTE()-1;1));8);"")2Worti=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")=WENN(LÄNGE($A2)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A2;SPALTE()-1;1));8);"")3Doc Holiday=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")=WENN(LÄNGE($A3)>=SPALTE()-1;DEZINBIN(CODE(TEIL($A3;SPALTE()-1;1));8);"")



mfg

H.B

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: