title image


Smiley Re: =WENN(N(B7)=0;B7;WENN(B7>0;B7*5;""))
hiho



das N nutze ich des öfteren um Texte auszutricksen



das ist aus der Hilfe



Gibt den in eine Zahl umgewandelten Wert zurück.



Syntax



N(Wert)



Wert ist der Wert, den Sie in eine Zahl umwandeln möchten. N wandelt Werte gemäß der folgenden Tabelle um.



Wert ist oder bezieht sich auf N gibt zurück

Eine Zahl Diese Zahl

Ein Datum in einem der eingebauten Datumsformate von Microsoft Excel Die fortlaufende Zahl dieses Datums

WAHR 1

FALSCH 0

Ein Fehlerwert, beispielsweise #DIV/0! Ein Fehlerwert

Sonstiges 0



Hinweise

Normalerweise ist es nicht erforderlich, die Funktion N innerhalb einer Formel einzusetzen, da Excel Werte bei Bedarf automatisch umwandelt. Diese Funktion steht aus Gründen der Kompatibilität zu anderen Tabellenkalkulationsprogrammen zur Verfügung.

Excel speichert Datumsangaben als fortlaufende Zahlen, um sie in Berechnungen verwenden zu können. Der 1. Januar 1900 wird standardmäßig als fortlaufende Zahl 1 gespeichert. Der 1. Januar 2008 wird beispielsweise als fortlaufende Zahl 39448 gespeichert, da dieses Datum 39.448 Tage auf den 1. Januar 1900 folgt. Excel für den Macintosh verwendet ein anderes Standarddatumssystem.

Beispiel



Das Beispiel ist möglicherweise leichter zu verstehen, wenn Sie es in ein leeres Arbeitsblatt kopieren.



Wie wird's gemacht?



Erstellen Sie eine leere Arbeitsmappe oder ein leeres Arbeitsblatt.

Wählen Sie das Beispiel im Hilfethema. Markieren Sie jedoch nicht die Zeilen- oder Spaltenüberschriften.





Auswählen eines Beispiels aus der Hilfe



Drücken Sie STRG+C.

Markieren Sie im Arbeitsblatt die Zelle A1, und drücken Sie dann STRG+V.

Um zwischen der Anzeige der Formel, die das Ergebnis liefert, und dem Ergebnis selbst umzuschalten, drücken Sie STRG+` (Graviszeichen). Sie können auch im Menü Extras auf Formelüberwachung zeigen und dann auf Formelüberwachungsmodus klicken.



1

2

3

4

5

A

Daten

7

Gerade

WAHR

17/04/2008

Formel Beschreibung (Ergebnis)

=N(A2) Da A2 eine Zahl enthält, wird diese zurückgegeben (7)

=N(A3) Da A3 Text enthält, wird 0 zurückgegeben (0, siehe oben)

=N(A4) Da A4 den logischen Wert WAHR enthält, wird 1 zurückgegeben (1, siehe oben)

=N(A5) Da A5 ein Datum enthält, wird die serielle Zahl zurückgegeben (variiert mit dem verwendeten Datumssystem)

=N("7") Da "7" Text darstellt, wird 0 zurückgegeben (0, siehe oben)




Feedback nicht vergessen ! Gutes gelingen wünscht Chris

I didn't write this; a very complex macro did.

0110110001101001011001010110001001100101001000000110011101110010111111001101111101100101001000000110001101101000011100100110100101110011

geschrieben von


Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: