title image


Smiley Re: JBOSS Probleme
Hallo

>müsste rein theoretisch im logfile stehen, wieso die applikation nicht läuft?



im Logfile steht MAPPING configuration error for request URI /appA

und die andere läuft



>was sagt der server denn beim hochkommen?

meldet keine Fehlermeldung



>was passiert, wenn eine applikation läuft und du die andere deployen willst?

passiert aber nix.



ich habe die Datei wo man mehrere Anwendungen konfigurieren kann

jboss-3.2.3\server\default\deploy\jbossweb-tomcat41.sar\META-INF\jboss-service.xml. Ich habe diese Datei erweitert.

attribute name="Config"

Server>

...

Service name="JBoss-Tomcat">

DefaultContext cookies="true" override="true"/>

Context path="/appA" docBase="appA" debug="0" reloadable="true"/>



Host>

Nach dieser Erweiterung start JBoss nicht richtig und meldet die folgende Fehlermeldung:

\jboss-3.2.3\server\default\.\appA does not exist or is not a readable directory





LifecycleException: Container StandardContext[/appA] has not been started

at org.apache.catalina.core.StandardContext.stop(StandardContext.java:3658)

at org.apache.catalina.core.StandardContext.start(StandardContext.java:3636)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1188)

at org.apache.catalina.core.StandardHost.start(StandardHost.java:754)

at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1188)

at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:363)



Die zweite Anwendung appB ist garnicht eingetragen. Aber es wird immer per Default übernommen



Danke



Gruss

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: