title image


Smiley Rundungsfehler durch Runden des Zwischenergebnisses "austricksen"
Hallo Volker,



es ist leider das "ewig alte Lied" : Excel rechnet tatsächlich in einigen Fällen aufgrund der internen Begrenzung auf 15 Stellen Genauigkeit falsch - und das leider auch bei solch anscheinend trivialen Berechnungen wie die von Dir genannte.



Mein Vorschlag wäre : Runde bereits die Zwischenergebnisse (siehe Spalte C) :



Funktionen der Tabelle :

 ABC1 Falsches ErgebnisRichtiges Ergebnis2Zahl115,0415,023Zahl215,0215,044Differenz=B2-B3=RUNDEN(C3-C2;2)5* 100=B4*100=C4*1006Gerundet=ABRUNDEN(B5;0)=ABRUNDEN(C5;0)

Ergebnisse der Tabelle :

 ABC1 Falsches ErgebnisRichtiges Ergebnis2Zahl115,0415,023Zahl215,0215,044Differenz0,020,025* 100226Gerundet12

Dies ist zwar keine Generallösung und auch nicht für alle Berechnungen anwendbar, aber vielleicht hilft es in Deinem Fall ja weiter.



Viel Erfolg !

Grüße, NoNet

  1,2,3 - kleine Excelei :   Infos + Anmeldung zum Jährlichen Exceltreffen



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: