title image


Smiley Re: Excel-Fkt. RGP
Hallo KeikoMan



Vielleicht hilft Dir folgender Auszug aus der Excelhilfe:

"Im Allgemeinen ist SUMME({m;b}*{x;1}) gleich mx + b; dies ist der geschätzte y-Wert eines gegebenen x-Wertes. Sie können dafür auch die TREND-Funktion verwenden."



Die Formel =Summe( .....) braucht 2 Arrays, nämlich {m;b} und {x;1} mit unseren Zahlen siehts dann so aus: {1000;2000} und {9;1}. Die komplette Formel mit unseren Zahlen: =SUMME({1000;2000}*{9;1}) wird dann von Excel so berechnet:

= 1000 * 9 + 2000 * 1 und ergibt unser Ergebnis: 9000+2000 = 11000



Die beiden Arrays {1000;2000} und {9;1} können mit der Hand eingetragen werden, dann funktionierts ja. Wenn nun das erste Array {1000;2000} über eine weitere Formel ermittelt wird - nämlich über =RGP(B2:B7;A2:A7) dann täte es ja auch funktionieren. Leider ist aber das Ergebnis von =RGP(B2:B7;A2:A7) nicht {1000;2000} sondern {1000.2000} und damit funktionierts nicht => =summe({1000.2000}*{9;1})

Deshalb ist beim zweiten Array der Strichpunkt in einen Punkt zu ändern =>

=summe({1000.2000}*{9.1})

=summe(RGP(B2:B7;A2:A7)*{9.1})



Nun zu Deinen Problemen:



a) =SUMME({1000;2000}*{9.1}) erhalte ich wieder 30000, mit der Formel

b) =SUMME({1000;2000}*{9;1}) bekomme ich das richtige Ergebnis 11000 !!!

Warum ?



in der Formel a) rechnet Excel:

=summe({9000,1000;18000,2000})

=summe(9000+1000+18000+2000) = 30000

in der Formel b) rechnet Excel:

=summe(1000*9+2000*1) = 11000

dies kannst Du auch über die Formelauswertung (Excel 2003) mitverfolgen:

Menü: Extras - Formelüberwachung - Formelauswertung

-------------------------

Warum muß ich die {9.1} oder {9;1} innerhalb der Formel in geschweifte Klammern schreiben { } ?

Du kannst in bestimmten Excelformeln als Argumente auch eine Matrix eingeben.

Dies kannst Du über einen Zellbereich definieren oder aber auch als Matrixkonstante direkt in die Formel eingeben:

Beispiel für Zellbereich als Matrix:

=Index(A1:C2;2;2) in der Funktion Index wurde als erstes Argument ein Bezug auf einen Zellbereich eingegeben; dieser Zellbereich stellt eine Matrix dar.

Beispiel für eine Matrixkonstante:

{5.8.12;4.7.9}

5 - 8 - 12

4 - 7 - 9

diese Matrixkonstante besteht aus zwei Zeilen mit je drei Spalten

die Werte in der gleichen Zeile werden durch einen Punkt getrennt

die Werte in den unterschiedlichen Zeilen werden durch einen Strichpunkt getrennt

------------------

Normalerweise erhält man die erst durch die Matrix-Tastenkombination STRG+SHIFT+RETURN und darf sie garnicht schreiben (weil man sonst ein falsches Ergebnis erhält).



Bei der ersten Frage haben wir die Argumente einer Formel und deren Erfassung in der Formel behandelt.

Bei dieser Frage gehts um spezielle Arrayformeln oder Matrixformeln. Eine "normale" Excelformel liefert als Ergebnis einen Wert z.B. =summe(2;5)

Eine Matrixformel enthält einerseits als Argument eine Matrix und liefert als Ergebnis für jedes Element dieser Matrix ein Ergebnis.

z.B.

Es sollen folgende Werte Zeilenweise multipliziert werden und dann die Gesamtsumme ermittelt werden.

1 - 5

2 - 6

3 - 7

4 - 8

5 - 9

Ohne Matrixformel: 1*5+2*6+3*7+4*8+5*9 = 115

mit Matrixformel: {=SUMME(A1:A5*B1:B5)} => 115

Hier sind die geschweiften Klammern mit STRG und SHIFT und RETURN

einzugeben.



Ich hoffe meine Hilfe verwirrt Dich nicht noch mehr sondern

bringt etwas Licht in die dunklen Ecken von Excel.



Viele Grüße

Herby





geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: