title image


Smiley Excel2003; Zählenwenn, minus eingefärbter Zellen
hallo

ich möchte in einer zellenreihe, in meinem fall a1:h1, alle vorkommen von "U" zählen und dabei

jene zellen die blau und rot eingefärbt sind und ein "U" enthalten abziehen.

mit nachstehender formel und dazugehöriger funktion funktioniert das auch.

mein problem ist jedoch wenn eine zelle mittels bedingter formatierung blau oder rot eingefärbt ist funktioniert es leider nicht. es sollte jedoch in beiden fällen funktionieren.

bitte wer könnte mir hier weiterhelfen?

danke im voraus

mfg johannes



=ZÄHLENWENN(A1:H1;"U") - (Farbe(A1:H1;33)+Farbe(A1:H1;3))





Function Farbe(rngBereich As Object, intColor As Integer)

Dim intCounter As Integer

Dim rngAct As Range



For Each rngAct In rngBereich

If rngAct.Interior.ColorIndex = intColor And _

rngAct.Text = "U" Then

intCounter = intCounter + 1

End If

Next rngAct

Farbe = intCounter

End Function

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: