title image


Smiley Alle Einträge ohne Dublikate zählen.
HiHo



ich hab da eine Liste mit Kennbegriffen. In der unsortierten Liste können diese Kennbegriffe aber leider mehrfach auftreten. Zu ermitteln gilt es die Anzahl der Kennbegriffe ohne Duplikate.



Probiert habe ich schon eine Variante von

http://www.excelformeln.de/formeln.html?welcher=79

Summe über die mit =WENN(ZÄHLENWENN(A$2:A2;A2)>1;0;1)

gefüllte Hilfsspalte.



und auch die Matrix-Variante

http://www.excelformeln.de/formeln.html?welcher=64

{=SUMME((ZÄHLENWENN(BEREICH.VERSCHIEBEN(A2;;;ZEILE(2:65536));A2:A65536)=1)*B2:B65536)}

über eine mit 1 gefüllte Hilfsspalte



Problem ist... die Liste ist >60.000 Zeilen lang.

Beide Formeln brauchen da so leider so ihre Zeit für... (auf dem schlappen rechner hier ca. 15 Minuten)



Access ist leider nicht vorhanden für ein select distinct :-(

Gibt es noch andere, schnellere Formeln? Oder doch besser per VBA ?



Gruß

Marco

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: