title image


Smiley Alle Artikel bestimmter Kathegorien (von 350) auflisten
Hi,



wurde etwas komplizierter.



Die Kathegorien der Gesamttabelle stehen in Spalte A.

Die Artikel in Spalte B.



In Spalte G ab G1 stehen die 173 Kathegorien.

in C1 steht =G1

in C2 steht:

=WENN(ZÄHLENWENN(A:A;INDIREKT("G"&SUMME((HÄUFIGKEIT(C$1:C1;C$1:C1)>0)*1)))=ZÄHLENWENN(C$1:C1;INDIREKT("G"&SUMME((HÄUFIGKEIT(C$1:C1;C$1:C1)>0)*1)));INDIREKT("G"&SUMME((HÄUFIGKEIT(C$1:C1;C$1:C1)>0)*1)+1);C1)

C2 runterkopieren



in D1 steht die Array-Formel:

{=INDEX(B:B;KKLEINSTE(WENN((A1:A1000=G1);ZEILE(1:1000));1))}

in D2 steht die Array-Formel:

{=INDEX(B:B;KKLEINSTE(WENN((A$1:A$1000=C2);ZEILE($1:$1000));ZÄHLENWENN(C$1:C2;C2)))}

D2 runterkopieren



ARRAY-Formel {=geschweifte Klammern} nicht eingeben;

Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.



trapp, trapp, trapp, trapp, trapp, brrrrr

WF


EXCELFORMELN die ultimative Formelseite

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: