title image


Smiley 2.Anleitung SVERWEIS (per VBA : Application.Worksheetfunction.Vlookup(...))
...hmmmm ... irgendwas stimmte wohl mit der Übertragung nicht, daher ein 2.Mal mein Beitrag (weshalb ist da eigentlich so eine grosse Lücke im Beitrag ??):



Hallo Matze,



die Syntax der SVERWEIS(.....)-Funktion ist eigentlich ganz einfach :



=SVERWEIS(Suchbegriff;Suchmatrix;Spaltenindex;Sortierflag)





Bedeutung der Parameter :

Suchbegriff

Zelladresse oder fixer Wert (falls Text : in " " einschließen), der gesucht wird

Suchmatrix

Zellbereich innerhalb dessen der Suchbegriff gesucht wird (Z.B. C6:F100)

Der Suchbegriff MUSS dabei in der ersten Spalte der Suchmatrix (hier also Spalte C) vorhanden sein !!

Spaltenindex

Die Spalte innerhalb der Suchmatrix, aus der das Ergebnis ausgelesen werden soll Falls aus der Matrix C6:F100 das Ergebnis aus Spalte D gelesen werden soll, muss Spaltenindex also 2 sein, da Spalte D die 2. Spalte der relevanten Matrix ist

Sortierflag (optional)

Falls Sortierflag=1 ist oder nicht angegeben wird, bedeutet das, dass die erste Spalte der Suchmatrix SORTIERT vorliegen muss. Falls diese Spalte nicht sortiert vorliegt, würde SVERWEIS den nächst kleineren Wert suchen (von Beginn der Matrix an gesehen) und diesen entsprechenden Wert aus der mit Spaltenindex angegeben Spalte ermitteln, was u.U. zu unerwünschten (fehlerhaften) Ergebnissen führen kann.

Falls Sortierflag=0 ist mus die erste Spalte der Suchmatrix nicht sortiert vorliegen, aber der Suchbegriff muss in der exakt gleichen Schreibweise enthalten sein.

Falls der Suchbegriff nicht in der ersten Spalte der Suchmatrix gefunden wurde, liefert die SVERWEIS(...)-Funktion das Ergebnis #NV! (das bedeutet "Nicht Vorhanden", bzw. #NA! für "Not Available" in der engl. Version !



Beispiel :

 CDEFGH1    Suchbegriff 2    PersonalnrName3    4713=SVERWEIS(G3;C6:F15;2;0)4Suchmatrix     5Personalnr.NameAbteilungBezirk  64711MeyerA1  74712MüllerB2  84713SchmidtC1  94714BauerA1  104715KunzeB1  114716FriedrichC2  124717VöllerA2  134718KohlB2  144719v.CubeC1  154720GibtesnetA2  

Ergebnis (siehe H3) :

 CDEFGH1    Suchbegriff 2    PersonalnrName3    4713Schmidt4Suchmatrix     5Personalnr.NameAbteilungBezirk  64711MeyerA1  74712MüllerB2  84713SchmidtC1  94714BauerA1  104715KunzeB1  114716FriedrichC2  124717VöllerA2  134718KohlB2  144719v.CubeC1  154720GibtesnetA2  

Das Ergebnis der SVERWEIS()-Funktion bei einer Suche in einer Nicht nach der ersten Spalte sortierten Suchmatrix :

 CDEFGH1    Suchbegriff 2    PersonalnrName3    4713#NV4Suchmatrix     5Personalnr.NameAbteilungBezirk  64714BauerA1  74716FriedrichC2  84720GibtesnetA2  94718KohlB2  104715KunzeB1  114711MeyerA1  124712MüllerB2  134713SchmidtC1  144719v.CubeC1  154717VöllerA2  

Hier müsste man als Sortierflag 0 angeben, damit das Ergebnis stimmt ! 





Der VBA-Befehl für z.B. diese Funktion :

=SVERWEIS(G3;C6:F15;2;0)



lautet unter VBA :

Application.Worksheetfunction.Vlookup(Range("G3"),Range("C6:F15"),2)







Das S in SVERWEIS steht übrigens NICHT (wie ich häufig höre oder lese) für "Spaltenverweis" oder "Suchverweis" sondern für die Suchrichtung, also "Senkrecht" (daher in VBA auch VLOOKUP, das steht für Vertical) bzw. bei den Pendants : WVERWEIS (also: Waagrecht) bzw. in VBA : HLOOKUP, also : Horizontal)



Auch Alexandra hat (wie ich richtig vermutete ) eine Anleitung zur SVERWEIS()-Funktion und den verwandten Funktionen auf ihrer sehr umfangreichen Webseite, siehe hier :

http://www.hrz.uni-dortmund.de/S3/alexandra/helpdesk/Excel/Fortgeschrittene/Formeln_fuer_statistische_Berechnungen.htm#Verweis_und_SVerweis_und_WVerweis



So, ich hoffe, das bringt etwas Licht in den SVERWEIS-Dschungel !

Grüße, NoNet

  1,2,3 - kleine Excelei :   Infos + Anmeldung zum Jährlichen Exceltreffen



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: