title image


Smiley Re: Es ist gelungen! Danke!
hi



{=WENN(ZEILE(A1)>ANZAHL2(Tabelle1!$C$67:$C$71);"";INDEX(Tabelle1!$C$67:$C$71;KKLEINSTE(WENN(Tabelle1!$C$67:$C$71"";ZEILE($1:$5));ZEILE(A1))))}





1. der leichte Teil

wenn(ZEILE(A1)>ANZAHL2(Tabelle1!$C$67:$C$71);"";



wenn 1 größer als gesamteinträge;dann nix, sonst .....

wenn 2 größer als gesamteinträge;dann nix, sonst .....

wenn 3 größer als gesamteinträge;dann nix, sonst .....

wenn 4 größer als gesamteinträge;dann nix, sonst .....

usw.



INDEX(Tabelle1!$C$67:$C$71;KKLEINSTE(WENN(Tabelle1!$C$67:$C$71"";ZEILE($1:$5));ZEILE(A1))))}





gebe die werte aus bereich wieder ($C$67:$C$71) das macht index->

index(bereich;zeile)



die zeile ist wie folgt def.



KKLEINSTE(WENN(Tabelle1!$C$67:$C$71"";ZEILE($1:$5));ZEILE(A1))))}



WENN(Tabelle1!$C$67:$C$71"";ZEILE($1:$5));



das liefert zum bsp {1;FALSCH;3;FALSCH;5} ->in der ersten Zeile ist ein Eintrag in der 3 und in der 5 Zeile



KKleinste -> macht daraus in der ersten Zeile 1 in der zweiten 3 in der dritten 5





in verbindung mit Kkleinste-> kleinster wert->zweitgrößter wert->drittgrößter wert usw...



das wäre wie

=index(c67:c71;1)

=index(c67:c71;3)

=index(c67:c71;5)



wenn eben c68 und c70 leer wären :-)





!!!! DIE GRÖSSTE SCHWIERIGKEIT BEI SOLCHEN FORMELN IST DIE MATRIX AN SICH {}



p.s zum testen von solchen Formeln kannst du F9 drücken (gewünschten Bereich in der Bearbeitungsleiste markieren und f9 drücken)

Gruß

chris


























Feedback nicht vergessen ! Gutes gelingen wünscht Chris



geschrieben von


Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: