title image


Smiley Anzahl bestimmter Wochentage zählen - Formelerläuterung
Hi Andreas,



=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT(D1&":"&D2));2)=1)*ISTNV(VERGLEICH(ZEILE(INDIREKT(D1&":"&D2));Feiertage;0)))



ZEILE(INDIREKT(D1&":"&D2)) bildet ein Array vom Anfang bis zum Enddatum. Steht in D1 z.B. '01.04.2004' und in D2 '30.04.2004', dann heisst es "übersetzt":



ZEILE(INDIREKT(38078&":"&38107)) bzw. dann ohne INDIREKT:

=ZEILE(38078:38107)



Umrandet wird das mit der Funktion WOCHENTAG, die jeden einzelnen "Tag" auf den Montag (=1) überprüft:

(WOCHENTAG(ZEILE(INDIREKT(D1&":"&D2));2)=1)



Ergebnis ist immer WAHR oder FALSCH.



In der 2. Bedingung wird nochmal jeder "Tag" mit der Feiertagsliste verglichen (VERGLEICH). Kommt der "Tag" nicht vor (=ISTNV), dann soll gezählt werden (WAHR):

ISTNV(VERGLEICH(ZEILE(INDIREKT(D1&":"&D2));Feiertage;0))



Und somit wird hier nur gezählt, wenn WAHR und WAHR multipliziert werden (=1), denn alles andere ergibt NULL. Und die Summe aller WAHR (Einser) gibt dann das gesucht Ergebnis.



Alles klar?



Grüße Boris
Grüße Boris

EXCELFORMELN die ultimative Formelseite

Seit Oktober 2006 ist es da: EXCEL - Das Zauberbuch

geschrieben von


Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: