title image


Smiley Re: Sucherei mit 'SVERWEIS' --- Hiiiiiiiilfe
Hallo Ernst,



ein paar grundsätzliche Erklärungen:

Es gibt den SVERWEIS in zwei Varianten:

1) "vierstufig" (so wie von mir vorgeschlagen): Vergleichsliste braucht nicht sortiert sein, es wird auf genaue Übereinstimmung geprüft:

 ABCDE3NrFirma NrFirma41=SVERWEIS(A4;$D$3:$E$8;2;0) 5Freitag5   1Montag6   3Mittwoch7   4Donnerstag8   2Dienstag

ergibt

 ABCDE3NrFirma NrFirma41Montag 5Freitag5   1Montag6   3Mittwoch7   4Donnerstag8   2Dienstag



2) dreistufig (wie bei dir bisher): Vergleichsliste muss aufsteigend sortiert sein - dabei findet eine "Klasseneinteilung" statt:

 ABCDE25ProzentNote ProzentNote2655%=SVERWEIS(A26;$D$26:$E$31;2) 0%ungenügend27   30%mangelhaft28   50%ausreichend29   67%befriedigend30   81%gut31   92%sehr gut

ergibt

 ABCDE25ProzentNote ProzentNote2655%ausreichend 0%ungenügend27   30%mangelhaft28   50%ausreichend29   67%befriedigend30   81%gut31   92%sehr gut



Damit ist klar, dass du bisher keinen #NV Fehler bekommen hast - denn wenn keine Übereinstimmung gefunden wurde, wurde einfach das nächste Konto zugeordnet (vielleicht wolltest du das??).



Den #NV - Fehler behandelt man z.B. folgendermaßen, indem man den "einfachen" SVERWEIS durch folgende Konstruktion ersetzt:



=WENN(ISTNV(SVERWEIS(...));"Fehlermeldung";SVERWEIS(...))



Viele Grüße



Ulrich






(Falls vorhanden:) Tabellen sind eingefügt mit Tool von Schorsch Dabbeljuh
hier sein offizieller Download-Link

(Fast) alles über Excel-Formeln ohne VBA findet man auf der Seite Excelformeln

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: