title image


Smiley Re: Suche VBA-Ansatz für ein magisches Quadrat
Hallo Ilka Maria,



zu

 ABCDEFGH1Dimension7  -1   2Startzahl7 -2    3        4 103518432651345 41174225503396 16482449328407 47235531739158 225430133814469 5329123720452110 28113619442752



gehören folgende Makros:

Sub Erzeugen()

Dim Tabelle() As Long

Dim Spalte, Zeile, Startzahl, Sp, Ze, N, k As Long



Sheets("allgemein").Select

Rows("4:256").Select

Selection.Delete Shift:=xlUp



N = Cells(1, 2)

Zeile = N

Spalte = 1

Startzahl = Cells(2, 2)

hinten = 0

ReDim Tabelle(1 To 2 * N - 1, 1 To 2 * N - 1)

For k = Startzahl To Startzahl + N * N - 1

Tabelle(Zeile, Spalte) = k

Zeile = Zeile - 1

Spalte = Spalte + 1

If Zeile = 0 + hinten Then

Zeile = N + 1 + hinten

Spalte = Spalte - N + 1

hinten = hinten + 1

End If

Next



For Ze = 1 To 2 * N - 1

For Sp = 1 To 2 * N - 1

If Ze = 2 * N - (N - 1) / 2 Or Sp >= 2 * N - (N - 1) / 2 Then

If Tabelle(Ze, Sp) > 0 Then

If Ze <= (N - 1) / 2 Then

Tabelle(Ze + N, Sp) = Tabelle(Ze, Sp)

Tabelle(Ze, Sp) = 0

End If

If Ze >= 2 * N - (N - 1) / 2 Then

Tabelle(Ze - N, Sp) = Tabelle(Ze, Sp)

Tabelle(Ze, Sp) = 0

End If

If Sp <= (N - 1) / 2 Then

Tabelle(Ze, Sp + N) = Tabelle(Ze, Sp)

Tabelle(Ze, Sp) = 0

End If

If Sp >= 2 * N - (N - 1) / 2 Then

Tabelle(Ze, Sp - N) = Tabelle(Ze, Sp)

Tabelle(Ze, Sp) = 0

End If

End If

End If

Next

Next







For Ze = 1 To 2 * N - 1

For Sp = 1 To 2 * N - 1

If Tabelle(Ze, Sp) 0 Then Cells(Ze + 3 - (N - 1) / 2, Sp - (N - 1) / 2 + 1) = Tabelle(Ze, Sp)

Next

Next

Cells.Select

Selection.Columns.AutoFit

Range("A1").Select



End Sub







(Ist nicht auf meinem eigenen Mist gewachsen - hab ich mal irgendwo gesehen und angepasst)



Viele Grüße



Ulrich



Und hier die Lösung mit Formeln:



 ABCDEFGHIJKLMN1Startzahl 1           2Dimension 3   =F3+1       3     =E4+1 =G4+1      4    =$C$1 =F5+1 =H5+1     5     =G2+1 =G6+1      6      =H3+1       7              8        =SUMME(F11;G10;H9)     9     =H10+1=H9+1=G10+1=SUMME(F9:H9)     10     =H11+1=F11+1=$C$1=SUMME(F10:H10)     11     =G11+1=F9+1=G9+1=SUMME(F11:H11)     12     =SUMME(F9:F11)=SUMME(G9:G11)=SUMME(H9:H11)=SUMME(F9;G10;H11)     13              14              15      =F16+1       16     =E17+1 =G17+1      17    =D18+1 =F18+1 =H18+1     18   =C19+1 =E19+1 =G19+1 =I19+1    19  =$C$1 =D20+1 =F20+1 =H20+1 =J20+1   20   =G15+1 =E21+1 =G21+1 =I21+1    21    =H16+1 =F22+1 =H22+1     22     =I17+1 =G23+1      23      =J18+1       24              25         =SUMME(E30;F29;G28;H27;I26)    26    =I27+1=I26+1=F27+1=G27+1=H27+1=SUMME(E26:I26)    27    =I28+1=E28+1=E27+1=G28+1=H28+1=SUMME(E27:I27)    28    =I29+1=E29+1=F29+1=$C$1=H29+1=SUMME(E28:I28)    29    =I30+1=E30+1=F30+1=G30+1=G29+1=SUMME(E29:I29)    30    =H30+1=E26+1=F26+1=G26+1=H26+1=SUMME(E30:I30)    31    =SUMME(E26:E30)=SUMME(F26:F30)=SUMME(G26:G30)=SUMME(H26:H30)=SUMME(I26:I30)=SUMME(E26;F27;G28;H29;I30)    32              33              34      =F35+1       35     =E36+1 =G36+1      36    =D37+1 =F37+1 =H37+1     37   =C38+1 =E38+1 =G38+1 =I38+1    38  =B39+1 =D39+1 =F39+1 =H39+1 =J39+1   39 =A40+1 =C40+1 =E40+1 =G40+1 =I40+1 =K40+1  40=$C$1 =B41+1 =D41+1 =F41+1 =H41+1 =J41+1 =L41+1 41 =G34+1 =C42+1 =E42+1 =G42+1 =I42+1 =K42+1  42  =H35+1 =D43+1 =F43+1 =H43+1 =J43+1   43   =I36+1 =E44+1 =G44+1 =I44+1    44    =J37+1 =F45+1 =H45+1     45     =K38+1 =G46+1      46      =L39+1       47              48          =SUMME(D55;E54;F53;G52;H51;I50;J49)   49   =J50+1=J49+1=E50+1=F50+1=G50+1=H50+1=I50+1=SUMME(D49:J49)   50   =J51+1=D51+1=D50+1=F51+1=G51+1=H51+1=I51+1=SUMME(D50:J50)   51   =J52+1=D52+1=E52+1=E51+1=G52+1=H52+1=I52+1=SUMME(D51:J51)   52   =J53+1=D53+1=E53+1=F53+1=$C$1=H53+1=I53+1=SUMME(D52:J52)   53   =J54+1=D54+1=E54+1=F54+1=G54+1=G53+1=I54+1=SUMME(D53:J53)   54   =J55+1=D55+1=E55+1=F55+1=G55+1=H55+1=H54+1=SUMME(D54:J54)   55   =I55+1=D49+1=E49+1=F49+1=G49+1=H49+1=I49+1=SUMME(D55:J55)   56   =SUMME(D49:D55)=SUMME(E49:E55)=SUMME(F49:F55)=SUMME(G49:G55)=SUMME(H49:H55)=SUMME(I49:I55)=SUMME(J49:J55)=SUMME(D49;E50;F51;G52;H53;I54;J55)   



ergibt

 ABCDEFGHIJKLMN1Startzahl 1           2Dimension 3   3       3     2 6      4    1 5 9     5     4 8      6      7       7              8        15     9     27615     10     95115     11     43815     12     15151515     13              14              15      5       16     4 10      17    3 9 15     18   2 8 14 20    19  1 7 13 19 25   20   6 12 18 24    21    11 17 23     22     16 22      23      21       24              25         65    26    3169221565    27    2082114265    28    7251311965    29    2412518665    30    11417102365    31    656565656565    32              33              34      7       35     6 14      36    5 13 21     37   4 12 20 28    38  3 11 19 27 35   39 2 10 18 26 34 42  401 9 17 25 33 41 49 41 8 16 24 32 40 48  42  15 23 31 39 47   43   22 30 38 46    44    29 37 45     45     36 44      46      43       47              48          175   49   4291237204528175   50   3511361944273175   51   1042184326234175   52   411749251339175   53   164824732840175   54   4723631143915175   55   2253013382146175   56   175175175175175175175175   


(Falls vorhanden:) Tabellen sind eingefügt mit Tool von Schorsch Dabbeljuh
hier sein offizieller Download-Link

(Fast) alles über Excel-Formeln ohne VBA findet man auf der Seite Excelformeln

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: