title image


Smiley lineare Interpolation (winzige Array-Formel)
Hi Toni,



Meßpunkte in Spalte A.

Meßwerte in Spalte B.

Meßpunkt für den der Meßwert linear interpoliert werden soll steht in E1.



{=WENN(ISTFEHLER(VERGLEICH(E1;A:A;0));((E1-MAX(WENN(A1:A100"")*A1:A100)))*INDEX(B:B;VERGLEICH(MIN(WENN(A1:A100>=E1;(A1:A100"")*A1:A100));A:A;0))+ABS(E1-MIN(WENN(A1:A100>=E1;(A1:A100"")*A1:A100)))*INDEX(B:B;VERGLEICH(MAX(WENN(A1:A100"")*A1:A100));A:A;0)))/(MIN(WENN(A1:A100>=E1;(A1:A100"")*A1:A100))-MAX(WENN(A1:A100"")*A1:A100)));INDEX(B:B;VERGLEICH(E1;A:A;0)))}



ARRAY-Formel {=geschweifte Klammern} nicht eingeben;

Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.



trapp, trapp, trapp, trapp, trapp, brrrrr

WF






EXCELFORMELN die ultimative Formelseite

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: