title image


Smiley Tabellennavigation - Blattnamen in Dropdown als variabler Hyperlink
Hi Andreas,



abgesehen davon, dass man das in der Tat rechts unten standardmäßig zur Verfügung hat, geht das auch mit Formeln.



Einfügen - Name - Festlegen / Definieren - Name: X

Bezieht sich auf:

=ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())



Schreibe in A1 folgende Formel und kopier sie weit genug runter:

=WENN(ZEILE(A1)>ANZAHL2(X);"";TEIL(INDEX(X;ZEILE(A1));FINDEN("]";INDEX(X;ZEILE(A1)))+1;31))



Im Ergebnis hast du jetzt alle Blattnamen aufgelistet.



Deine Gültigkeitszelle sei mal D1.

Dort schreibt du unter Daten-Gültigkeit-Liste:

=INDIREKT("A1:A"&SUMME(N($A$1:$A$100"")))



Und in E1 schreibst du:

=HYPERLINK("#'"&D1&"'!A1";"Wechsel zu Blatt "&D1)



Im Ergebnis wird immer das Blatt in E1 verlinkt, welches in D1 ausgewählt wurde.



Grüße Boris
Grüße Boris

EXCELFORMELN die ultimative Formelseite

Seit Oktober 2006 ist es da: EXCEL - Das Zauberbuch

geschrieben von


Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: