title image


Smiley Sechser-Nullsummenspiel - war ne hammerharte Nuß - aber reizvoll !
Hi Marco,



Soooo langweilig kann ein Karfreitag sein - oder ich hab mich total vergalloppiert!



Die Namen stehen in A1 bis A6

Die entsprechenden Beträge, die in Summe Null ergeben, in B1 bis B6



in C2 steht die Array-Formel:

{=WENN(VORZEICHEN(B$1)=VORZEICHEN(B2);0;MIN(ABS(B$1)-SUMME(ABS(C$1:C1));ABS(B2)))*VORZEICHEN(B$1)}

bis C6 kopieren

in D3:

{=WENN(VORZEICHEN(H$2)=VORZEICHEN(H3);0;MIN(ABS(H$2)-SUMME(ABS(D$2:D2));ABS(H3)))*VORZEICHEN(H$2)}

bis D6 kopieren

in E4:

{=WENN(VORZEICHEN(I$3)=VORZEICHEN(I4);0;MIN(ABS(I$3)-SUMME(ABS(E$3:E3));ABS(I4)))*VORZEICHEN(I$3)}

bis E6 kopieren

in F5:

{=WENN(VORZEICHEN(J$4)=VORZEICHEN(J5);0;MIN(ABS(J$4)-SUMME(ABS(F$4:F4));ABS(J5)))*VORZEICHEN(J$4)}

bis F6 kopieren

und in G6:

{=WENN(VORZEICHEN(K$5)=VORZEICHEN(K6);0;MIN(ABS(K$5)-SUMME(ABS(G$5:G5));ABS(K6)))*VORZEICHEN(K$5)}



ARRAY-Formel {=geschweifte Klammern} nicht eingeben;

Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.



in H2 steht:

=B2+C2

bis H6 kopieren



in i2 steht:

=H2+D2

bis i6:L6 kopieren



Die Ergebnisse (Name 1 bis 6):

=A1&" "&WENN(B1=0;"";WENN(B1<0;"zahlt an ";"erhält von"))&WENN(C2=0;"";A2&": "&ABS(C2))&WENN(C3=0;"";" "&A3&": "&ABS(C3))&WENN(C4=0;"";" "&A4&": "&ABS(C4))&WENN(C5=0;"";" "&A5&": "&ABS(C5))&WENN(C6=0;"";" "&A6&": "&ABS(C6))



=A2&" "&WENN(B2=0;"";WENN(B2<0;"zahlt an ";"erhält von "))&WENN(C2=0;"";A1&": "&ABS(C2))&WENN(D3=0;"";" "&A3&": "&ABS(D3))&WENN(D4=0;"";" "&A4&": "&ABS(D4))&WENN(D5=0;"";" "&A5&": "&ABS(D5))&WENN(D6=0;"";" "&A6&": "&ABS(D6))



=A3&" "&WENN(B3=0;"";WENN(B3<0;"zahlt an ";"erhält von "))&WENN(C3=0;"";A1&": "&ABS(C3))&WENN(D3=0;"";" "&A2&": "&ABS(D3))&WENN(E4=0;"";" "&A4&": "&ABS(E4))&WENN(E5=0;"";" "&A5&": "&ABS(E5))&WENN(E6=0;"";" "&A6&": "&ABS(E6))



=A4&" "&WENN(B4=0;"";WENN(B4<0;"zahlt an ";"erhält von "))&WENN(C4=0;"";A1&": "&ABS(C4))&WENN(D4=0;"";" "&A2&": "&ABS(D4))&WENN(E4=0;"";" "&A3&": "&ABS(E4))&WENN(F5=0;"";" "&A5&": "&ABS(F5))&WENN(F6=0;"";" "&A6&": "&ABS(F6))



=A5&" "&WENN(B5=0;"";WENN(B5<0;"zahlt an ";"erhält von "))&WENN(C5=0;"";A1&": "&ABS(C5))&WENN(D5=0;"";" "&A2&": "&ABS(D5))&WENN(E5=0;"";" "&A3&": "&ABS(E5))&WENN(F5=0;"";" "&A4&": "&ABS(F5))&WENN(G6=0;"";" "&A6&": "&ABS(G6))



=A6&" "&WENN(B6=0;"";WENN(B6<0;"zahlt an ";"erhält von "))&WENN(C6=0;"";A1&": "&ABS(C6))&WENN(D6=0;"";" "&A2&": "&ABS(D6))&WENN(E6=0;"";" "&A3&": "&ABS(E6))&WENN(F6=0;"";" "&A4&": "&ABS(F6))&WENN(G6=0;"";" "&A5&": "&ABS(G6))



trapp, trapp, trapp, trapp, trapp, brrrrr

WF





www.excelformeln.de - die ultimative Formelseite


EXCELFORMELN die ultimative Formelseite

geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: