title image


Smiley Auswertung Kalenderwoche - jeweils Samstags
Hey guenbeck,



eine Idee wäre es, die Auswertung im Kalender jeweils Samstags durchzuführen, da an diesem Tag ohnehin keine Daten eingetragen werden.



So würde die Tabelle aussehen (Funktionen) :

 ABCD1 MeierMüllerSchmidt201.04.2005101010302.04.2005=WENN(WOCHENTAG($A3;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A3;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A3;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")403.04.2005=WENN(WOCHENTAG($A4;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A4;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A4;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")504.04.2005101010605.04.2005101010706.04.2005101010807.04.2005101010908.04.20051010101009.04.2005=WENN(WOCHENTAG($A10;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A10;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A10;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")1110.04.2005=WENN(WOCHENTAG($A11;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")  1211.04.2005710101312.04.2005810101413.04.2005910101514.04.20051010101615.04.20051110101716.04.2005=WENN(WOCHENTAG($A17;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A17;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A17;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")1817.04.2005=WENN(WOCHENTAG($A18;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A18;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A18;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")1918.04.2005=WENN(WOCHENTAG($A19;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102019.04.2005=WENN(WOCHENTAG($A20;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102120.04.2005=WENN(WOCHENTAG($A21;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102221.04.2005=WENN(WOCHENTAG($A22;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102322.04.2005=WENN(WOCHENTAG($A23;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102423.04.2005=WENN(WOCHENTAG($A24;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A24;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A24;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")2524.04.2005=WENN(WOCHENTAG($A25;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A25;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A25;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")2625.04.2005=WENN(WOCHENTAG($A26;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102726.04.2005=WENN(WOCHENTAG($A27;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102827.04.2005=WENN(WOCHENTAG($A28;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10102928.04.2005=WENN(WOCHENTAG($A29;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10103029.04.2005=WENN(WOCHENTAG($A30;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")10103130.04.2005=WENN(WOCHENTAG($A31;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A31;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")=WENN(WOCHENTAG($A31;2)=6;SUMME(INDIREKT(ADRESSE(MAX(ZEILE()-5;2);SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())));"")



Ergebnis :

 ABCD1 MeierMüllerSchmidt201.04.2005101010302.04.2005101010403.04.2005   504.04.2005101010605.04.2005101010706.04.2005101010807.04.2005101010908.04.20051010101009.04.20055050501110.04.2005   1211.04.2005710101312.04.2005810101413.04.2005910101514.04.20051010101615.04.20051110101716.04.20054550501817.04.2005   1918.04.2005 10102019.04.2005 10102120.04.2005 10102221.04.2005 10102322.04.2005 10102423.04.2005050502524.04.2005   2625.04.2005 10102726.04.2005 10102827.04.2005 10102928.04.2005 10103029.04.2005 10103130.04.200505050

Um die Zellen entsprechend einzufärben kann man die Bereiche folgendermassen mit "Format - Bedingte Formatierung" ( formatieren :

A2:C31 : Formel ist : =WOCHENTAG($A2;2)>5 - Format - Muster - (Farbe auswählen) - OK


Grüße, NoNet

  1,2,3 - kleine Excelei :   Infos + Anmeldung zum Jährlichen Exceltreffen



geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: