title image


Smiley Ich schätz mal...
... dass da irgendwelche Paketabhängigkeiten nicht erfüllt sind. Ist bei SuSE sowieso etwas kritisch das Zeug nicht aus nem RPM raus zu installieren. Geht natürlich schon, aber man muss sicherstellen, dass die RPM-Datenbank konsistent bleibt. D.h. bevor Du ein Paket selbst compilierst, stell sicher, dass kein konkurrierendes Paket installiert ist. Hab grad kein "normales" Linux zur Hand und kann's deshalb nur frei Schnautze formulieren - Ich hoff es stimmt trotzdem einigermassen. Schau also erst mal nach, ob curl nicht schon RPM-technisch installiert ist

root@lfs ~# curl -V

curl 7.10.4 (i586-pc-linux-gnu) libcurl/7.10.4 OpenSSL/0.9.7a ipv6 zlib/1.1.4

root@lfs ~# type -a curl

curl is /usr/bin/curl

root@lfs ~# rpm -qf /usr/bin/curl # geht bei mir nicht, hab kein rpm ;-)

root@lfs ~#



Ok, das sollte bei Dir idealerweise komplett fehlschlagen, denn Dein curl tut ja anscheinend nicht. Wenn rpm aber doch was vernünftiges liefert, dann deinstalliere das Ding erst mal mit yast oder rpm!



Nun braucht curl aber einige Pakete und wir müssen sicherstellen, dass die auch da sind. Die mir bekannten Abhängigkeiten sind:

- openssl-0.9.7a

- zlib-1.1.4

- openldap-2.1.17

- db-4.1.25



Schau nach, ob die Dinger überhaupt und wenn ja, ob sie in einer ausreichenden Version da sind. Eigentlich brauchste da nicht gross rumsuchen, denn Dein ./configure oder make werden Dir schon sagen, was fehlt - Schau die Ausgabe kritisch an!. Nun kann's aber sein, dass das geforderte Teil zwar eigentlich da ist, aber trotzdem nicht gefunden wird. Der Grund ist, dass die meisten Quellpakete ihr Zeug defaultmässig in /usr/local/ installieren. Ich bin zwar kein Freund von dieser Wahl, aber grundsätzlich gehen tut's schon. Wenn sich nun eines oder mehrere Pakete in /usr/local/ befinden, dann stell sicher, dass in der /etc/ld.so.config folgende Zeile vorkommt

/usr/local/lib



Führ nun ein ldconfig aus und probier's nochmal. Achtung: Nach ner fehlgeschlagenen Installation ist's immer die sicherste Methode, den kompletten Sourcetree zu löschen und neu zu entpacken!

Wenn's nun immer noch nicht tut, dann schick mir mal die kompletten Aufrufe mitsamt den Meldungen per Mail (mailto: ccay).

Eventuell findest Du auch dort Hilfe.



Viele Grüsse,



Uli







geschrieben von

Login

E-Mail:
  

Passwort:
  

Beitrag anfügen

Symbol:
 
 
 
 
 
 
 
 
 
 
 
 
 

Überschrift: